Die schnelle Reparatur zwischendurch: Tektronix 11802 mit E5622

Kurz vor Weihnachten ist bei mir zwar kein dicker Mann mit weißem Bart stehen geblieben, aber ich bekam einen Anruf: „Du, hier steht ein bisschen Gerät rum, dass du vor dem Schrott retten kannst.“

Also gut, mal hin und ein Gerät entdeckt, auf dass ich sogar schon ein paar mal mehr oder weniger lustlos bei eBay geboten hatte: Ein Tektronix Samplingscope der 11000er-Serie.

Diese Serie von Tektronix besteht aus nur sehr wenigen Geräten und ist recht hoch spezialisiert in ihrer Anwendung: Ganz schnelle, digitale Signale. Es handelt sich um reinrassige Sampling-scopes, die keinerlei „Echtzeit“-Fähigkeit haben. Gesampelt wird mit bis zu 200 kS/s, also voll lahm.

Warum ich sowas will? Jedes China-Scope kann ja heutzutage 1 GS/s oder mehr… ja… aber… die Tektronix-Einschübe (auch die 11000er Serie ist Einschub-basiert) gehen in ihrer analogen Bandbreite unglaublich hoch. Der schnellste Einschub, der SD-32, hat eine analoge Bandbreite von bis zu 50 GHz!!

Wenn man sich z.B. mit schweineschneller Logik beschäftigt und sich ansehen möchte, ob die Pulse aus den Baugruppen so aussehen, wie man sich das vorstellt: Voila, das ist deine Kiste!

Und genau hier ist meine Anwendung, hin und wieder befasse ich mich mit dem Design einigermaßen flotter Pulsgeneratoren um Frequenzkämme bis in den GHz-Bereich zu erzeugen. Da ist es natürlich nett, auch mal die Anstiegszeit qualifiziert messen zu können. Vor dem Hintergrund bin ich, wie geschrieben, schon ein paar mal um so eine Kiste herum geschwänzelt.

Naja, jetzt ist es soweit. Einladen, heim fahren, ausladen:

Etwas Beifang ist auch noch dabei, ein HP 54111D und etwas Kleinkram.

Bestandsaufnahme:

Die Einschübe hat man mir nicht mit in den Container geworfen, welch Ärger.

Der optische Zustand ist schön, ein paar Aufkleber, die runter wollen, sonst nichts.

Es liegt eine Notitz bei, „Nicht reparierbar“ – Na, das wollen wir mal sehen.

Erster Blick: Ja, 230V sind eingestellt. Also Stecker rein und anschalten.

Nix knallt, öde.

Die LEDs der Frontplatte blinken, es klickt hin und wieder ein Relais und auf dem Monitor wird mir mitgeteilt, dass der Selbsttest läuft. Nach etwa 30 Sekunden spielt das Tek die fröhliche Melodie eines fatalen Fehlers, bleibt hängen und präsentiert: E5622

E5622 gehört zur Kategorie der schwerwiegenden Selbsttest-Fehler des Zeitbasis-Boards, man kommt aus dem extended-test-Menü nicht raus: Die Kiste bleibt stur und macht nix.

Uff…

Aber, Tante Google weiß wie so oft Rat und findet einen Eintrag aus der Tek-Mailingliste auf groups.io: https://groups.io/g/TekScopes/topic/11801_diagnostic_help/30445357?p=

Alles halb so wild, wenn der Fehler auftritt heißt das höchstwahrscheinlich die NVRAMs sind platt. Dabei handelt es sich um zwei Feld-Wald-Wiesen-RAM-Chips, die in speziellen Sockeln von Dallas stecken (Typ DS1213, gibts aber nicht mehr), die eine Batterie enthalten. Nach 25 Jahren ist die nun platt und damit auch das RAM, der Inhalt ist weg. Das ist aber wohl gar kein Problem, wird dort geschrieben. Neue NVRAMs gibt es, das ST M48Z35-70PC1. Einfach rein Stecken, ein paar mal ein und aus schalten und die Kiste läuft wieder.

Ob die NVRAMs wirklich platt sind, lässt sich ja leicht überprüfen: Da sie ja gesockelt sind, müsste ich die Vcc messen können. Hier erlebe ich eine positive Überraschung: die Cal-Aufkleber von Tektronix sind oben wie unten noch unversehrt auf der Kiste, da war also niemand drin und hat versucht irgendwas zu reparieren.

Ich weiß garnicht, wie viele völlig verpfuschte Kisten ich schon hatte. Mir ist es immer am liebsten, der Fehler ist noch jungfräulich. Das „Gewerk“ von anderen erst mal mit großem Aufwand rückbauen zu müssen, ist nun nicht gerade die helle Freude. Nicht, dass ich besser bin was Pfusch angeht, aber dann ist es wenigstens MEIN Mist… 🙂

Nimmt man den Geräteboden ab, sind die NVRAMs direkt zugänglich. Das Schlimmste ist es also, das schwere Gerät auf die Werkbank zu wuchten.

Kurz gemssen:

Gerät an 5V.

Gerät aus 1 mV.

So wird das nichts mit NV.

Hier sieht man im ausgebauten Zustand schön den Puffer-Sockel von Dallas:

Also am Sonntag den 20.12. noch schnell bei Mouser die NVRAMs bestellt. 21.12. Versand und am 23.12. morgens um 9 Uhr steht Fedex vor der Tür. Und das Paket kam aus den USA. Verrückte Welt.

Die Chips sind schnell getauscht und Tatsache, es kommt Bewegung in das Gerät: Neue Fehlermeldung T1331. Das bedeutet, dass der Inhalt des NVRAMs nicht okay ist. Welch Wunder.

Ein und Ausschalten hat bei mir nichts gebracht. Aber einmal den Selbsttest bei eingeschaltetem Gerät nochmals durchlaufen zu lassen hat alle Fehlemeldungen vertrieben. Das war’s. Gerät läuft wieder. Sogar die Uhr geht noch fast richtig.

Nun brauchte ich noch Einschübe. Wie mein Glück es will, ist bei eBay just zu diesem Zeitpunkt ein SD-26 zu einem Vernünftigen Preis drin. Der SD-26 ist ein Sampling-Kopf mit einer Bandbreite von 20 GHz und zwei Kanälen. 3…2…1… Meins.

Genau am 31.12. ist das Paket da, schaffe ich den Projektabschluss noch 2020? Feiern fällt ja eh aus, auch wenn allein das natürlich ein Feuerwerk wert gewesen wäre 😉

Flux ins Gerät damit und… voila, ich seh’ was.

Ich hab einen schnellen Puls-Generator von Leo Bodnar, der packt laut Spezifikation 28,4 ps Anstiegszeit. Mit dem SD-26 messe ich eine Anstiegszeit von 33 ps.

Zunächst etwas Verwundert fange ich an zu überlegen. Die 4-5 ps Unterschied kann ich ja so nicht auf mir sitzen lassen. Was, wenn der neu gekaufte Sampler defekt ist?

Da so schnelle Pulse und deren Betrachtung für mich Neuland sind, muss ich wiedermal etwas nachlesen und recherchieren. Nach kurzer Zeit komme ich der Sache schon deutlich nahe: Da der SD-26 aber mit der eigenen Anstiegszeit von 17,5 ps noch signifikant in das Ergebnis einspielt, muss ein etwas schlechteres Ergebnis heraus kommen. Nach etwas Rechnen, die Zeiten kann man quadriert addieren und dann die Wurzel ziehen, mit den beiden bekannten Zeiten komme ich auch genau auf 33 ps. Passt!

Das ist eine, zumindest für mich, neue Erkenntnis: Betrachte ich die Anstiegszeit von einem Puls, muss mein Messgerät nicht nur deutlich sondern sehr erheblich schneller sein, sonst verfälscht es das Ergebnis. 4-5 ps sind nicht viel, bei dem hier gemessenen Puls-Generator aber ist die Spezifikation 30+-2 ps. D.h. nach meiner Messung wäre er nicht mehr innerhalb.

Anschließend noch ein kleiner Test: Ich nutze einen HP 8671B Synthi als Quelle und Triggere auf die 10 MHz-Referenzfrequenz.

Hier zu sehen, 18,5 GHz im Zeitbereich, etwas rauschig, aber gut auszumachen. Das Rauschen ist vermutlich zu weiten Teilen der niedrige Triggerpegel (aus dem 8671 kommt die Referenz nur mit 0dBm raus).

Wunderbar. Ich bin zufrieden. Jetzt werde ich mich auf die Lauer legen, weitere Einschübe zu ergattern. Insbesondere einer der 30er wäre gut, aber die Preise sind teilweise doch recht happig.

Noch einige Worte zu diesen Geräten. Das sind wirklich ziemlich spezielle Kisten und auch ausgesprochen unhandlich in der Bedienung: Sie können prinzipbedingt nicht mehr (bzw. Nur eingeschränkt) auf das Signal triggern. Sonst bräuchte man ja eine Triggerschaltung, die auch 20 GHz oder mehr Bandbreite hat. Also mal eben ein Signal einspeisen und angucken, das geht nicht.

Hier muss man sich mit Techniken behelfen:

1) Trigger-Eingang. Um bei dem Puls-Generator von Leo Bodnar zu bleiben. Der hat einen zweiten Anschluss aus dem eine Triggerflanke kommt, die mit der steilen Pulsflanke korrespondiert. Wenn man sowas hat: Gewonnen!

2) Clock-Ausgnag: Der 11802 gibt seine interne Clock aus, wenn man also sein Messobejkt an den Takt des Messgerätes anpassen kann, ist es auch einfach.

3) Delay-Line: Der 11802 hat im Gegensatz zum 11801C/CSA802 nur eingeschränktere Software-Funktionen. Dafür hat er aber in seiner aqusition-unit zwei delay-lines. In diesen ist auch ein Leistungsteiler, der auf den Triggereingang gelegt werden kann. So kann auf das Signal getriggert werden, dies geht aber nur für Pulse (schnelle Flanke, moderate Wiederholrate), nicht für CW-Signale. Die Bandbreite der Delay-Lines ist natürlich beschränkt.

Das gilt alles natürlich nur für richtig flotte Signale. Ein 100 kHz Sinussignal speist man einfach in den Triggereingang parallel mit ein, fertig. Aber ein 11000er ist nun wirklich nichts, um sich einen 100 kHz Sinus anzugucken. Das ist wie mit dem Prosche einen Umzug zu machen, geht, ist aber irgendwie blöd.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.